Como solucionar problema de incompatibilidad de versión de WordPress y qTranslate

 

Hola todos:

qTranslate es un maravilloso plugin que nos permite tener nuestro sitio creado con WordPress en varios idiomas.

Sin embargo ya me ha pasado que varias veces que cuando actualizo a una nueva versión de WordPress qTranslate se desactiva mostrando este mensaje:

The qTranslate Editor has disabled itself because it hasn’t been tested with your WordPress version yet. This is done to prevent WordPress from malfunctioning. You can reenable it by clicking here (may cause data loss! Use at own risk!). To remove this message permanently, please update qTranslate to the corresponding version.

Reconozco que la primera vez que me paso me asusté y tome la drástica decisión de volver a la versión anterior de wordpress, aquí explico como volver a una versión anterior de wordpress.

Curioseando en el código de qTranslate me di cuenta que que la solución es mucho más sencilla.

Para poder utilizar la versión más reciente de WordPress con el plugin qTranslate antes de que este se actualice solo tenemos en entras en la carpeta plugins que se encuentra dentro de wp-content, localizar la carpeta qtranslate y dentro de esta editar el archivo qtranslate.php.

Tenemos que localizar la linea donde pone:

define('QT_SUPPORTED_WP_VERSION', 'x.x.x');

Donde ‘x.x.x’ será la versión de WordPress que soporta qTranslate, debéis poner la versión actual de WordPress que tenéis instalada.

Y con este pequeño cambio ya podemos seguir usando qTranslate hasta que se actualice para la versión actual de wordpress.

Hay que tener en cuenta la advertencia que aparece en el en el comentario que se encuentra justo encima :

 // qTranslate Editor will only activated for the given version of WordPress.
// Can be changed to use with other versions but might cause problems and/or data loss!

Que viene a decir que puedes cambiar a otra versión pero que podría causar problemas o perdida de datos,en principio los cambios de una versión a otra no suelen ser lo suficientemente grandes como para causar problemas, intenta actualizar qTranslate en cuanto salga la siguiente versión.

Eso es todo por hoy.

¿Necesitas un presupuesto para  un desarrollo WordPress a medida?

¿Quieres un plugin a medida que realice una funcionalidad concreta que necesitas para tu WordPress?

Solicita un presupuesto  sin compromiso:

Un saludo, y si aún no lo has hecho no olvides suscribirte a mi blog para no perderte los próximos posts  :-),
 

También puedes seguirme en Twitter en ‎@revigames y no olvides que me ayudas mucho si compartes este post en las redes sociales.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.